CVE-2026-39999
Critical
Description
Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Apisix
PublishedJun 19, 2026
First seenJun 19, 2026
Weakness typeCWE-290CWE-290
How to fix
Update
- apache apisix3.17.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache apisix | 2.2 ≤ v < 3.17.0 | 3.17.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.