CVE-2026-40352

High

Description

FastGPT is an AI Agent building platform. In versions prior to 4.14.9.5, the password change endpoint is vulnerable to NoSQL injection. An authenticated attacker can bypass the "old password" verification by injecting MongoDB query operators. This allows an attacker who has gained a low-privileged session to change the password of their account (or others if combined with ID manipulation) without knowing the current one, leading to full account takeover and persistence. This issue has been fixed in version 4.14.9.5.

SeverityHigh
CVSS8.8
Exploit probability—
ProductFastgpt
PublishedApr 17, 2026
First seenApr 17, 2026
Weakness typeCWE-943CWE-943

How to fix

Update
  • fastgpt fastgpt4.14.9.5 or later

Affected products

ProductAffected versionsFixed in
fastgpt fastgptv < 4.14.9.54.14.9.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.