CVE-2026-40452
High
Description
Incorrect Authorization, Improper Access Control vulnerability in Apache IoTDB. Authorization bypass in /rest/v2/fastLastQuery exposes last-value data to unauthorized authenticated users. This issue affects Apache IoTDB: from 1.3.5 before 1.3.8, from 2.0.5 before 2.0.10. Users are recommended to upgrade to version 2.0.10, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
ProductApache IoTDB
PublishedJul 10, 2026
First seenJul 10, 2026
How to fix
Update
- Apache Software Foundation Apache IoTDB1.3.8, 2.0.10 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache IoTDB | 1.3.5 ≤ v < 1.3.8, 2.0.5 ≤ v < 2.0.10 | 1.3.8, 2.0.10 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.