CVE-2026-40459
High
Description
PAC4J is vulnerable to LDAP Injection in multiple methods. A low-privileged remote attacker can inject crafted LDAP syntax into ID-based search parameters, potentially resulting in unauthorized LDAP queries and arbitrary directory operations. This issue was fixed in PAC4J versions 4.5.10, 5.7.10 and 6.4.1
SeverityHigh
CVSS8.8
Exploit probability—
ProductPac4j
PublishedApr 17, 2026
First seenApr 17, 2026
Weakness typeCWE-90CWE-90
How to fix
Update
- pac4j pac4j4.5.10, 5.7.10, 6.4.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| pac4j pac4j | 4.0.0 ≤ v < 4.5.10, 5.0.0 ≤ v < 5.7.10, 6.0.0 ≤ v < 6.4.1 | 4.5.10, 5.7.10, 6.4.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.