CVE-2026-40466

High

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated attacker may bypass the fix in CVE-2026-34197 by adding a connector using an HTTP Discovery transport via BrokerView.addNetworkConnector or BrokerView.addConnector through Jolokia if the activemq-http module is on the classpath. A malicious HTTP endpoint can return a VM transport through the HTTP URI which will bypass the validation added in CVE-2026-34197. The attacker can then use the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 5.19.6 or 6.2.5, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Activemq
PublishedApr 24, 2026
First seenApr 24, 2026

How to fix

Update
  • apache activemq5.19.6, 6.2.5 or later
  • apache activemq_broker5.19.6, 6.2.5 or later
  • org.apache.activemq:apache-activemq5.19.6, 6.2.5 or later
  • org.apache.activemq:activemq-all5.19.6, 6.2.5 or later
  • org.apache.activemq:activemq-broker5.19.6, 6.2.5 or later

Affected products

ProductAffected versionsFixed in
apache activemqv < 5.19.6, 6.0.0 ≤ v < 6.2.55.19.6, 6.2.5
apache activemq_brokerv < 5.19.6, 6.0.0 ≤ v < 6.2.55.19.6, 6.2.5
org.apache.activemq:apache-activemqMavenv < 5.19.6, 6.0.0 ≤ v < 6.2.55.19.6, 6.2.5
org.apache.activemq:activemq-allMavenv < 5.19.6, 6.0.0 ≤ v < 6.2.55.19.6, 6.2.5
org.apache.activemq:activemq-brokerMavenv < 5.19.6, 6.0.0 ≤ v < 6.2.55.19.6, 6.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-40466 · Apache Activemq · Dark Radar