CVE-2026-41041
Critical
Description
URL path injection via unencoded user-supplied identifiers vulnerability in Apache Gravitino. This issue affects Apache Gravitino: from 1.0.0 before 1.2.1. Users are recommended to upgrade to version 1.2.1, which fixes the issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Gravitino
PublishedJul 13, 2026
First seenJul 13, 2026
Weakness typeCWE-177CWE-177
How to fix
Update
- apache gravitino1.2.1 or later
- apache-gravitino1.2.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache gravitino | 1.0.0 ≤ v < 1.2.1 | 1.2.1 |
| apache-gravitinoPyPI | 1.0.0 ≤ v < 1.2.1 | 1.2.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.