CVE-2026-41043
Description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
How to fix
- apache activemq5.19.6, 6.2.5 or later
- apache activemq_web5.19.6, 6.2.5 or later
- org.apache.activemq:apache-activemq5.19.6, 6.2.5 or later
- org.apache.activemq:activemq-all5.19.6, 6.2.5 or later
- org.apache.activemq:activemq-broker5.19.6, 6.2.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache activemq | v < 5.19.6, 6.0.0 ≤ v < 6.2.5 | 5.19.6, 6.2.5 |
| apache activemq_web | v < 5.19.6, 6.0.0 ≤ v < 6.2.5 | 5.19.6, 6.2.5 |
| org.apache.activemq:apache-activemqMaven | v < 5.19.6, 6.0.0 ≤ v < 6.2.5 | 5.19.6, 6.2.5 |
| org.apache.activemq:activemq-allMaven | v < 5.19.6, 6.0.0 ≤ v < 6.2.5 | 5.19.6, 6.2.5 |
| org.apache.activemq:activemq-brokerMaven | v < 5.19.6, 6.0.0 ≤ v < 6.2.5 | 5.19.6, 6.2.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.