CVE-2026-41140

High

Description

Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.

SeverityHigh
CVSS8.7
Exploit probability—
ProductPoetry
PublishedApr 24, 2026
First seenApr 24, 2026

How to fix

Update
  • poetry2.3.4 or later

Affected products

ProductAffected versionsFixed in
poetryPyPIv < 2.3.42.3.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.