CVE-2026-41264

Critical

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the specific flaw exists within the run method of the CSV_Agents class. The issue results from the lack of proper sandboxing when evaluating an LLM generated python script. An attacker can leverage this vulnerability to execute code in the context of the user running the server. Using prompt injection techniques, an unauthenticated attacker with the ability to send prompts to a chatflow using the CSV Agent node may convince an LLM to respond with a malicious python script that executes attacker controlled commands on the Flowise server. This vulnerability is fixed in 3.1.0.

SeverityCritical
CVSS9.8
Exploit probability—
ProductFlowise
PublishedApr 23, 2026
First seenApr 23, 2026
Weakness typeCWE-184CWE-184

How to fix

Update
  • flowiseai flowise3.1.0 or later
  • flowise3.1.0 or later
  • flowise-components3.1.0 or later

Affected products

ProductAffected versionsFixed in
flowiseai flowisev < 3.1.03.1.0
flowisenpmv < 3.1.03.1.0
flowise-componentsnpmv < 3.1.03.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.