CVE-2026-41268

Critical

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

SeverityCritical
CVSS9.8
Exploit probability—
ProductFlowise
PublishedApr 23, 2026
First seenApr 23, 2026

How to fix

Update
  • flowiseai flowise3.1.0 or later
  • flowise3.1.0 or later
  • flowise-components3.1.0 or later

Affected products

ProductAffected versionsFixed in
flowiseai flowisev < 3.1.03.1.0
flowisenpmv < 3.1.03.1.0
flowise-componentsnpmv < 3.1.03.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.