CVE-2026-41270

High

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) protection bypass vulnerability exists in the Custom Function feature. While the application implements SSRF protection via HTTP_DENY_LIST for axios and node-fetch libraries, the built-in Node.js http, https, and net modules are allowed in the NodeVM sandbox without equivalent protection. This allows authenticated users to bypass SSRF controls and access internal network resources (e.g., cloud provider metadata services) This vulnerability is fixed in 3.1.0.

SeverityHigh
CVSS7.1
Exploit probability—
ProductFlowise
PublishedApr 23, 2026
First seenApr 23, 2026

How to fix

Update
  • flowiseai flowise3.1.0 or later
  • flowise3.1.0 or later
  • flowise-components3.1.0 or later

Affected products

ProductAffected versionsFixed in
flowiseai flowisev < 3.1.03.1.0
flowisenpmv < 3.1.03.1.0
flowise-componentsnpmv < 3.1.03.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-41270 · Flowise · Dark Radar