CVE-2026-41271

High

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.

SeverityHigh
CVSS8.3
Exploit probability—
ProductFlowise
PublishedApr 23, 2026
First seenApr 23, 2026

How to fix

Update
  • flowiseai flowise3.1.0 or later
  • flowise3.1.0 or later
  • flowise-components3.1.0 or later

Affected products

ProductAffected versionsFixed in
flowiseai flowisev < 3.1.03.1.0
flowisenpmv < 3.1.03.1.0
flowise-componentsnpmv < 3.1.03.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.