CVE-2026-41273

High

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise contains an authentication bypass vulnerability that allows an unauthenticated attacker to obtain OAuth 2.0 access tokens associated with a public chatflow. By accessing a public chatflow configuration endpoint, an attacker can retrieve internal workflow data, including OAuth credential identifiers, which can then be used to refresh and obtain valid OAuth 2.0 access tokens without authentication. This vulnerability is fixed in 3.1.0.

SeverityHigh
CVSS8.2
Exploit probability—
ProductFlowise
PublishedApr 23, 2026
First seenApr 23, 2026

How to fix

Update
  • flowiseai flowise3.1.0 or later
  • flowise3.1.0 or later

Affected products

ProductAffected versionsFixed in
flowiseai flowisev < 3.1.03.1.0
flowisenpmv < 3.1.03.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.