CVE-2026-41415

Critical

Description

PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an out-of-bounds read when parsing a malformed Content-ID URI in SIP multipart message body. Insufficient length validation can cause reads beyond the intended buffer bounds. This vulnerability is fixed in 2.17.

SeverityCritical
CVSS9.1
Exploit probability—
ProductTeluu Pjsip
PublishedApr 24, 2026
First seenApr 24, 2026

How to fix

Update
  • teluu pjsip2.17 or later

Affected products

ProductAffected versionsFixed in
teluu pjsipv < 2.172.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.