CVE-2026-41487

Medium

Description

Langfuse is an open source large language model engineering platform. From version 3.68.0 to before version 3.167.0, there is a role-based-access control flaw in the LLM connection update flow. An authenticated, low-privileged user of role “member” in a project could request the update of an existing LLM connection to an attacker-controlled baseUrl, causing Langfuse to reuse the stored provider secret and redirect the test request to an attacker-controlled endpoint. This could expose the plaintext provider LLM API key for that connection. The attack is only possible if a user is already part of a project and has “member” scoped access. This issue has been patched in version 3.167.0.

SeverityMedium
CVSS5.4
Exploit probability—
ProductLangfuse
PublishedMay 8, 2026
First seenMay 8, 2026

How to fix

Update
  • langfuse langfuse3.167.0 or later

Affected products

ProductAffected versionsFixed in
langfuse langfuse3.68.0 ≤ v < 3.167.03.167.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.