CVE-2026-41607

Medium

Description

Out-of-bounds Read vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Thrift
PublishedApr 28, 2026
First seenApr 28, 2026

How to fix

Affected products

ProductAffected versionsFixed in
apache thriftv < 0.23.00.23.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.