CVE-2026-41677

Critical

Description

rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.

SeverityCritical
CVSS9.1
Exploit probability—
ProductRust-openssl
PublishedApr 24, 2026
First seenApr 24, 2026

How to fix

Update
  • rust-openssl_project rust-openssl0.10.78 or later

Affected products

ProductAffected versionsFixed in
rust-openssl_project rust-openssl0.9.0 ≤ v < 0.10.780.10.78

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-41677 · Rust-openssl · Dark Radar