CVE-2026-41680
Description
Marked is a markdown parser and compiler. From 18.0.0 to 18.0.1, a critical Denial of Service (DoS) vulnerability exists in marked. By providing a specific 3-byte input sequence a tab, a vertical tab, and a newline (\x09\x0b\n)—an unauthenticated attacker can trigger an infinite recursion loop during parsing. This leads to unbounded memory allocation, causing the host Node.js application to crash via Memory Exhaustion (OOM). This vulnerability is fixed in 18.0.2.
How to fix
- marked_project marked18.0.2 or later
- marked18.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| marked_project marked | 18.0.0 ≤ v < 18.0.2 | 18.0.2 |
| markednpm | 18.0.0 ≤ v < 18.0.2 | 18.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.