CVE-2026-41887

Medium

Description

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

SeverityMedium
CVSS4.9
Exploit probability—
ProductFlarum/core
PublishedMay 8, 2026
First seenMay 8, 2026

How to fix

Update
  • flarum/core1.8.16, 2.0.0-rc.1 or later

Affected products

ProductAffected versionsFixed in
flarum/corePackagistv < 1.8.16, 2.0.0-beta.1 ≤ v < 2.0.0-rc.11.8.16, 2.0.0-rc.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.