CVE-2026-42076

Critical

Description

Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a command injection vulnerability in the _extractLLM() function allows attackers to execute arbitrary shell commands on the server. The function constructs a curl command using string concatenation and passes it to execSync() without proper sanitization, enabling remote code execution when the corpus parameter contains shell metacharacters. This issue has been patched in version 1.69.3.

SeverityCritical
CVSS9.8
Exploit probability—
Product@evomap/evolver
PublishedMay 4, 2026
First seenMay 4, 2026

How to fix

Update
  • @evomap/evolver1.69.3 or later

Affected products

ProductAffected versionsFixed in
@evomap/evolvernpmv < 1.69.31.69.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.