CVE-2026-42089

High

Description

Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

SeverityHigh
CVSS8.6
Exploit probability—
ProductYeoman-environment
PublishedJun 16, 2026
First seenJun 16, 2026
Weakness typeCWE-829CWE-829

How to fix

Update
  • yeoman-environment6.0.1 or later

Affected products

ProductAffected versionsFixed in
yeoman-environmentnpm2.9.0 ≤ v < 6.0.16.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.