CVE-2026-42268
High
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
SeverityHigh
CVSS7.5
Exploit probability—
ProductOwasp Modsecurity
PublishedMay 12, 2026
First seenMay 12, 2026
Weakness typeCWE-191CWE-191CWE-248CWE-248
How to fix
Update
- owasp modsecurity3.0.15 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| owasp modsecurity | 3.0.0 ≤ v < 3.0.15 | 3.0.15 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.