CVE-2026-42271

HighActively exploited (CISA KEV)

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

SeverityHigh
CVSS8.8
Exploit probability—
ProductBerriAI LiteLLM
PublishedMay 8, 2026
First seenMay 8, 2026
Added to KEVJun 8, 2026

How to fix

CISA required action

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

CISA due date: Jun 22, 2026
Update
  • litellm litellm1.83.7 or later
  • redhat openshift_ai2.25.8, 3.3.4 or later
  • litellm1.83.7 or later

Affected products

ProductAffected versionsFixed in
litellm litellm1.74.2 ≤ v < 1.83.71.83.7
redhat openshift_ai2.25 ≤ v < 2.25.8, 3.3 ≤ v < 3.3.4, 3.42.25.8, 3.3.4
litellmPyPI1.74.2 ≤ v < 1.83.71.83.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.