CVE-2026-42280
High
Description
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.
SeverityHigh
CVSS7.1
Exploit probability—
Product
Auth0.js
PublishedMay 27, 2026
First seenMay 27, 2026
Weakness typeCWE-863Incorrect authorization
How to fix
Update
- auth0 auth0.js10.0.0 or later
- auth0-js10.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| auth0 auth0.js | 8.11.0 ≤ v < 10.0.0 | 10.0.0 |
| auth0-jsnpm | 8.11.0 ≤ v < 10.0.0 | 10.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.