CVE-2026-42307

Medium

Description

Vim is an open source, command line text editor. Prior to version 9.2.0383, an OS command injection vulnerability exists in the netrw standard plugin bundled with Vim. By inducing a user to open a crafted URL (e.g., using the sftp:// or file:// protocol handlers), an attacker can execute arbitrary shell commands with the privileges of the Vim process. This issue has been patched in version 9.2.0383.

SeverityMedium
CVSS4.4
Exploit probability—
ProductVim
PublishedMay 8, 2026
First seenMay 8, 2026

How to fix

Update
  • vim vim9.2.0383 or later

Affected products

ProductAffected versionsFixed in
vim vimv < 9.2.03839.2.0383

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.