CVE-2026-42311
High
Description
Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.
SeverityHigh
CVSS7.8
Exploit probability—
Product
Python Pillow
PublishedMay 9, 2026
First seenMay 9, 2026
Weakness typeCWE-190Integer overflowCWE-787Out-of-bounds write
How to fix
Update
- python pillow12.2.0 or later
- pillow12.2.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| python pillow | 10.3.0 ≤ v < 12.2.0 | 12.2.0 |
| pillowPyPI | 10.3.0 ≤ v < 12.2.0 | 12.2.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.