CVE-2026-42334

High

Description

Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.

SeverityHigh
CVSS7.5
Exploit probability—
ProductMongoose
PublishedMay 14, 2026
First seenMay 14, 2026
Weakness typeCWE-74Injection

How to fix

Update
  • mongoosejs mongoose6.13.9, 7.8.9, 8.22.1, 9.1.6 or later
  • mongoose6.13.9, 7.8.9, 8.22.1, 9.1.6 or later

Affected products

ProductAffected versionsFixed in
mongoosejs mongoosev < 6.13.9, 7.0.0 ≤ v < 7.8.9, 8.0.0 ≤ v < 8.22.1, 9.0.0 ≤ v < 9.1.66.13.9, 7.8.9, 8.22.1, 9.1.6
mongoosenpmv < 6.13.9, 7.0.0 ≤ v < 7.8.9, 8.0.0 ≤ v < 8.22.1, 9.0.0 ≤ v < 9.1.66.13.9, 7.8.9, 8.22.1, 9.1.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.