CVE-2026-42536
High
Description
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Http Server
PublishedJun 8, 2026
First seenJun 8, 2026
Weakness typeCWE-122CWE-122
How to fix
Update
- apache http_server2.4.68 or later
Vendor advisories
- httpd.apache.org/security/vulnerabilities_24.html
- access.redhat.com/errata/RHSA-2026:56868
- access.redhat.com/errata/RHSA-2026:47046
- access.redhat.com/errata/RHSA-2026:34109
- access.redhat.com/errata/RHSA-2026:42828
- access.redhat.com/errata/RHSA-2026:67152
- access.redhat.com/errata/RHSA-2026:66323
- access.redhat.com/errata/RHSA-2026:62165
- access.redhat.com/errata/RHSA-2026:41906
- access.redhat.com/errata/RHSA-2026:25042
- access.redhat.com/errata/RHSA-2026:53371
- access.redhat.com/errata/RHSA-2026:56869
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache http_server | 2.4.0 ≤ v < 2.4.68 | 2.4.68 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.