CVE-2026-42569

Critical

Description

phpVMS is a PHP application to run and simulate an airline. Prior to version 7.0.6, a critical vulnerability in phpVMS allowed unauthenticated access to a legacy import feature. This issue has been patched in version 7.0.6.

SeverityCritical
CVSS9.4
Exploit probability—
ProductNabeel/phpvms
PublishedMay 9, 2026
First seenMay 9, 2026

How to fix

Update
  • nabeel/phpvms7.0.6 or later

Affected products

ProductAffected versionsFixed in
nabeel/phpvmsPackagistv < 7.0.67.0.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.