CVE-2026-42585
Medium
Description
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty incorrectly parses malformed Transfer-Encoding, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
SeverityMedium
CVSS6.5
Exploit probability—
ProductNetty
PublishedMay 13, 2026
First seenMay 13, 2026
Weakness typeCWE-444CWE-444
How to fix
Update
- netty netty4.1.133, 4.2.13 or later
- io.netty:netty-codec-http4.2.13.Final, 4.1.133.Final or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| netty netty | v < 4.1.133, 4.2.0 ≤ v < 4.2.13 | 4.1.133, 4.2.13 |
| io.netty:netty-codec-httpMaven | 4.2.0.Alpha1 ≤ v < 4.2.13.Final, v < 4.1.133.Final | 4.2.13.Final, 4.1.133.Final |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.