CVE-2026-42782

High

Description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

SeverityHigh
CVSS7.2
Exploit probability—
ProductApache Syncope
PublishedMay 25, 2026
First seenMay 25, 2026
Weakness typeCWE-653CWE-653

How to fix

Update
  • apache syncope4.0.6 or later
  • org.apache.syncope.core:syncope-core-spring4.0.6, 4.1.1 or later

Affected products

ProductAffected versionsFixed in
apache syncope3.0.0 ≤ v ≤ 3.0.16, 4.0.0 ≤ v < 4.0.6, 4.1.04.0.6
org.apache.syncope.core:syncope-core-springMaven3.0.0-M0 ≤ v ≤ 3.0.16, 4.0.0-M0 ≤ v < 4.0.6, 4.1.0-M0 ≤ v < 4.1.14.0.6, 4.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.