CVE-2026-42797
Description
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
How to fix
- apache syncope4.0.6 or later
- org.apache.syncope.core:syncope-core-provisioning-api4.0.6, 4.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache syncope | 3.0.0 ≤ v ≤ 3.0.16, 4.0.0 ≤ v < 4.0.6, 4.1.0 | 4.0.6 |
| org.apache.syncope.core:syncope-core-provisioning-apiMaven | 3.0.0-M0 ≤ v ≤ 3.0.16, 4.0.0-M0 ≤ v < 4.0.6, 4.1.0-M0 ≤ v < 4.1.1 | 4.0.6, 4.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.