CVE-2026-42842

Medium

Description

The form plugin for Grav adds the ability to create and use forms. Prior to 9.1.0, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Grav CMS Form plugin's select field template. Taxonomy tag and category values are rendered with the Twig |raw filter in the admin panel, bypassing the global autoescape protection. An editor-level user can inject arbitrary JavaScript that executes in any administrator's browser session when they view or edit any page in the admin panel. This vulnerability is fixed in 9.1.0.

SeverityMedium
CVSS5.4
Exploit probability—
ProductGetgrav/grav
PublishedMay 11, 2026
First seenMay 11, 2026

How to fix

Update
  • getgrav/grav2.0.0-beta.2 or later

Affected products

ProductAffected versionsFixed in
getgrav/gravPackagistv < 2.0.0-beta.22.0.0-beta.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.