CVE-2026-42849
Critical
Description
authentik is an open-source identity provider. Prior to versions 2025.12.5 and 2026.2.3, due to the implementation of stages in the SFE (Simple Flow Executor) in order to make the interface more compatible with legacy browsers, it was possible to use an XSS exploit in the AutosubmitStage. This issue has been patched in versions 2025.12.5 and 2026.2.3.
SeverityCritical
CVSS9.3
Exploit probability—
ProductAuthentik
PublishedJun 2, 2026
First seenJun 2, 2026
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- goauthentik authentik2025.12.5, 2026.2.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| goauthentik authentik | v < 2025.12.5, 2026.2.0 ≤ v < 2026.2.3 | 2025.12.5, 2026.2.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.