CVE-2026-4295

High

Description

Improper trust boundary enforcement in Kiro IDE before version 0.8.0 on all supported platforms might allow a remote unauthenticated threat actor to execute arbitrary code via maliciously crafted project directory files that bypass workspace trust protections when a local user opens the directory. To remediate this issue, users should upgrade to version 0.8.0 or higher.

SeverityHigh
CVSS7.8
Exploit probability—
ProductKiro IDE
PublishedMar 17, 2026
First seenMar 17, 2026
Weakness typeCWE-829CWE-829

How to fix

Affected products

ProductAffected versionsFixed in
AWS Kiro IDE0.1.0 ≤ v < 0.8.00.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-4295 · Kiro IDE · Dark Radar