CVE-2026-4296
Description
An incorrect regular expression vulnerability was identified in GitHub Enterprise Server that allowed an attacker to bypass OAuth redirect URI validation. An attacker with knowledge of a first-party OAuth application's registered callback URL could craft a malicious authorization link that, when clicked by a victim, would redirect the OAuth authorization code to an attacker-controlled domain. This could allow the attacker to gain unauthorized access to the victim's account with the scopes granted to the OAuth application. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.1, 3.19.5, 3.18.8, 3.17.14, 3.16.17, 3.15.21, 3.14.26. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.14.26, 3.15.21, 3.16.17, 3.17.14, 3.18.8, 3.19.5 or later
- docs.github.com/en/[email protected]/admin/release-notes#3.14.26
- docs.github.com/en/[email protected]/admin/release-notes#3.15.21
- docs.github.com/en/[email protected]/admin/release-notes#3.16.17
- docs.github.com/en/[email protected]/admin/release-notes#3.17.14
- docs.github.com/en/[email protected]/admin/release-notes#3.18.8
- docs.github.com/en/[email protected]/admin/release-notes#3.19.5
- docs.github.com/en/[email protected]/admin/release-notes#3.20.1
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.14.26, 3.15.0 ≤ v < 3.15.21, 3.16.0 ≤ v < 3.16.17, 3.17.0 ≤ v < 3.17.14, 3.18.0 ≤ v < 3.18.8, 3.19.0 ≤ v < 3.19.5, 3.20.0 | 3.14.26, 3.15.21, 3.16.17, 3.17.14, 3.18.8, 3.19.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.