CVE-2026-43512

Critical

Description

DEPRECATED: Authentication Bypass Issues vulnerability in digest authentication in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from before 7.0.0. Older unsupported versions any also be affect Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Tomcat
PublishedMay 12, 2026
First seenMay 12, 2026
Weakness typeCWE-592CWE-592

How to fix

Update
  • apache tomcat9.0.118, 10.1.55, 11.0.22 or later
  • org.apache.tomcat.embed:tomcat-embed-core9.0.118, 10.1.55, 11.0.22 or later
  • org.apache.tomcat:tomcat9.0.118, 10.1.55, 11.0.22 or later
  • org.apache.tomcat:tomcat-catalina9.0.118, 10.1.55, 11.0.22 or later

Affected products

ProductAffected versionsFixed in
apache tomcat7.0.0 ≤ v ≤ 7.0.109, 8.5.0 ≤ v ≤ 8.5.100, 9.0.0 ≤ v < 9.0.118, 10.1.0 ≤ v < 10.1.55, 11.0.0 ≤ v < 11.0.229.0.118, 10.1.55, 11.0.22
org.apache.tomcat.embed:tomcat-embed-coreMavenv < 9.0.118, 10.1.0-M1 ≤ v < 10.1.55, 11.0.0-M1 ≤ v < 11.0.229.0.118, 10.1.55, 11.0.22
org.apache.tomcat:tomcatMavenv < 9.0.118, 10.1.0-M1 ≤ v < 10.1.55, 11.0.0-M1 ≤ v < 11.0.229.0.118, 10.1.55, 11.0.22
org.apache.tomcat:tomcat-catalinaMavenv < 9.0.118, 10.1.0-M1 ≤ v < 10.1.55, 11.0.0-M1 ≤ v < 11.0.229.0.118, 10.1.55, 11.0.22

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.