CVE-2026-43646
High
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Wicket
PublishedMay 6, 2026
First seenMay 6, 2026
Weakness typeCWE-200Sensitive information exposure
How to fix
Update
- apache wicket10.9.0 or later
- org.apache.wicket:wicket-parent10.9.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache wicket | 8.0.0 ≤ v ≤ 8.17.0, 9.0.0 ≤ v ≤ 9.22.0, 10.0.0 ≤ v < 10.9.0 | 10.9.0 |
| org.apache.wicket:wicket-parentMaven | 8.0.0-M1 ≤ v ≤ 8.17.0, 9.0.0-M1 ≤ v ≤ 9.22.0, 10.0.0-M1 ≤ v < 10.9.0 | 10.9.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.