CVE-2026-43869

High

Description

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Thrift
PublishedMay 5, 2026
First seenMay 5, 2026
Weakness typeCWE-297CWE-297

How to fix

Affected products

ProductAffected versionsFixed in
apache thriftv < 0.23.00.23.0
org.apache.thrift:libthriftMavenv < 0.23.00.23.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.