CVE-2026-43944
Description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.
How to fix
- electerm_project electerm3.8.15 or later
- electerm3.8.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| electerm_project electerm | 3.0.6 ≤ v < 3.8.15 | 3.8.15 |
| electermnpm | 3.0.6 ≤ v < 3.8.8 | 3.8.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.