CVE-2026-44166
Description
Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.
How to fix
- pocketbase pocketbase0.22.42, 0.37.4 or later
- github.com/pocketbase/pocketbase0.22.42, 0.37.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| pocketbase pocketbase | v < 0.22.42, 0.23.0 ≤ v < 0.37.4 | 0.22.42, 0.37.4 |
| github.com/pocketbase/pocketbaseGo | v < 0.22.42, 0.30.0 ≤ v < 0.37.4 | 0.22.42, 0.37.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.