CVE-2026-44167
High
Description
phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.
SeverityHigh
CVSS7.5
Exploit probability—
ProductPhpseclib/phpseclib
PublishedMay 12, 2026
First seenMay 12, 2026
Weakness typeCWE-400Uncontrolled resource consumption
How to fix
Update
- phpseclib/phpseclib1.0.29, 2.0.54, 3.0.52 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| phpseclib/phpseclibPackagist | 0.1.1 ≤ v < 1.0.29, 2.0.0 ≤ v < 2.0.54, 3.0.0 ≤ v < 3.0.52 | 1.0.29, 2.0.54, 3.0.52 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.