CVE-2026-44194

Critical

Description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.

SeverityCritical
CVSS9.1
Exploit probability—
ProductOpnsense
PublishedMay 13, 2026
First seenMay 13, 2026

How to fix

Update
  • opnsense opnsense26.1.8 or later

Affected products

ProductAffected versionsFixed in
opnsense opnsensev < 26.1.826.1.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-44194 · Opnsense · Dark Radar