CVE-2026-44222

Medium

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.6.1 to before 0.20.0, there is a a Token Injection vulnerability in vLLM’s multimodal processing. Unauthenticated, text-only prompts that spell special tokens are interpreted as control. Image and video placeholder sequences supplied without matching data cause vLLM to index into empty grids during input-position computation, raising an unhandled IndexError and terminating the worker or degrading availability. Multimodal paths that rely on image_grid_thw/video_grid_thw are affected. This vulnerability is fixed in 0.20.0.

SeverityMedium
CVSS6.5
Exploit probability—
ProductVllm
PublishedMay 12, 2026
First seenMay 12, 2026
Weakness typeCWE-129CWE-129

How to fix

Update
  • vllm vllm0.20.0 or later
  • vllm0.20.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.6.1 ≤ v < 0.20.00.20.0
vllmPyPI0.6.1 ≤ v < 0.20.00.20.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.