CVE-2026-44416
Critical
Description
Remote Code Execution via Arbitrary Class Instantiation in plugin-schema-registry component in Apache Ranger <= 2.8.0. Users are recommended to upgrade to version 2.9.0, which fixes this issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Ranger
PublishedAug 10, 2026
First seenAug 10, 2026
Weakness typeCWE-94Code injectionCWE-470CWE-470
How to fix
Update
- apache ranger2.9.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache ranger | v < 2.9.0 | 2.9.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.