CVE-2026-44488
Description
Axios is a promise based HTTP client for the browser and Node.js. Axios versions 1.7.0 through 1.15.x did not enforce configured request and response size limits when requests were sent with the fetch adapter. Applications that selected adapter: 'fetch', or ran in environments where axios resolved to the fetch adapter, could receive or send bodies larger than maxContentLength or maxBodyLength despite those limits being explicitly configured. This can cause resource exhaustion in server-side usage when a malicious or compromised server returns an oversized response, when an attacker can supply a large data: URL, or when an application forwards attacker-controlled request bodies through axios while relying on maxBodyLength as a boundary. This vulnerability is fixed in 0.32.0 and 1.16.0.
How to fix
- axios axios1.16.0 or later
- axios1.16.0 or later
- access.redhat.com/errata/RHSA-2026:42078
- access.redhat.com/errata/RHSA-2026:34160
- access.redhat.com/errata/RHSA-2026:66545
- access.redhat.com/errata/RHSA-2026:66488
- access.redhat.com/errata/RHSA-2026:41064
- access.redhat.com/errata/RHSA-2026:30651
- access.redhat.com/errata/RHSA-2026:36882
- access.redhat.com/errata/RHSA-2026:46903
- access.redhat.com/errata/RHSA-2026:57191
- access.redhat.com/errata/RHSA-2026:20938
- access.redhat.com/errata/RHSA-2026:20889
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| axios axios | 1.7.0 ≤ v < 1.16.0 | 1.16.0 |
| axiosnpm | 1.7.0 ≤ v < 1.16.0 | 1.16.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.