CVE-2026-44573
Description
Next.js is a React framework for building full-stack web applications. From 12.2.0 to before 15.5.16 and 16.2.5, Applications using the Pages Router with i18n configured and middleware/proxy-based authorization can allow unauthorized access to protected page data through locale-less /_next/data/<buildId>/<page>.json requests. In affected configurations, middleware does not run for the unprefixed data route, allowing an attacker to retrieve SSR JSON for protected pages without passing the intended authorization checks. This vulnerability is fixed in 15.5.16 and 16.2.5.
How to fix
- vercel next.js15.5.16, 16.2.5 or later
- next15.5.16, 16.2.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 12.2.0 ≤ v < 15.5.16, 16.0.0 ≤ v < 16.2.5 | 15.5.16, 16.2.5 |
| nextnpm | 12.2.0 ≤ v < 15.5.16, 16.0.0 ≤ v < 16.2.5 | 15.5.16, 16.2.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.