CVE-2026-44580
Description
Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
How to fix
- vercel next.js15.5.16, 16.2.5 or later
- next15.5.16, 16.2.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 13.0.0 ≤ v < 15.5.16, 16.0.0 ≤ v < 16.2.5 | 15.5.16, 16.2.5 |
| nextnpm | 13.0.0 ≤ v < 15.5.16, 16.0.0 ≤ v < 16.2.5 | 15.5.16, 16.2.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.