CVE-2026-44618

Medium

Description

Insecure XML parser configuration in Apache CXF's WS-Transfer module may allow attackers to perform XXE attacks. Users are recommended to upgrade to versions 4.2.1, 4.1.6 or 3.6.11, which fix this issue.

SeverityMedium
CVSS5.3
Exploit probability—
ProductApache Cxf
PublishedMay 22, 2026
First seenMay 22, 2026

How to fix

Update
  • apache cxf3.6.11, 4.1.6 or later
  • org.apache.cxf:cxf-rt-ws-transfer4.2.1, 4.1.6, 3.6.11 or later

Affected products

ProductAffected versionsFixed in
apache cxfv < 3.6.11, 4.0.0 ≤ v < 4.1.6, 4.2.03.6.11, 4.1.6
org.apache.cxf:cxf-rt-ws-transferMaven4.2.0 ≤ v < 4.2.1, 4.1.0 ≤ v < 4.1.6, v < 3.6.114.2.1, 4.1.6, 3.6.11

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.