CVE-2026-44631
Critical
Description
Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Http Server
PublishedJun 8, 2026
First seenJun 8, 2026
Weakness typeCWE-124CWE-124
How to fix
Update
- apache http_server2.4.68 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache http_server | 2.4.0 ≤ v < 2.4.68 | 2.4.68 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.